Login    Register
  • Author
    Message

Bad water pump system symptoms?

Postby emarkey » Fri, 01 Jan 2016 11:29 +0000

What are the symptoms of a bad water pump?
My mx5 over heated a bit while idling for a while, but the rad didn't get hot so I assumed the water wasn't being pumped around. There could have been an air pocket, because I started it there yesterday and it didn't over heat at all. Just making sure because I'm changing the timing belt soon and you know "while I'm in there".
emarkey
***
 
Posts: 271
Joined: Tue, 06 May 2014 11:59 +0000

Re: Bad water pump system symptoms?

Postby MX5Spares » Fri, 01 Jan 2016 4:58 +0000

Hi Eoin,definitely change the pump if changing the belt.Otherwise if pump leaks afterwards or overheating issue not resolved you will be stripping it all out again anyway .Crazy not to change pump while doing belt
MX5Spares
*****
 
Posts: 2235
Joined: Wed, 22 Sep 2010 4:59 +0000
Location: dublin,

Re: Bad water pump system symptoms?

Postby emarkey » Sun, 03 Jan 2016 12:38 +0000

Cool. Thanks!
emarkey
***
 
Posts: 271
Joined: Tue, 06 May 2014 11:59 +0000

Re: Bad water pump system symptoms?

Postby sidewaysreilly » Thu, 07 Jan 2016 9:21 +0000

Get a new thermostat too.
The perfection of a Car's beauty is that nothing should be there for beauty's sake.
sidewaysreilly
*****

User avatar
 
Posts: 2113
Joined: Wed, 02 Sep 2009 5:56 +0000
Location: Around Ireland

Re: Bad water pump system symptoms?

Postby leamyj » Fri, 18 Mar 2016 10:04 +0000

Take a look at the rad, does it need flushing?
leamyj
*****

User avatar
 
Posts: 5186
Joined: Sat, 04 Aug 2007 2:19 +0000
Location: kildare

Return to Engine Mods

Who is online

Users browsing this forum: No registered users and 1 guest

cron